Scheduled Website Maintenance
Incident Report for Kabataan Partylist
Resolved
KPL website was successfully migrated to Google Project Shield.
Posted Jul 07, 2021 - 13:44 GMT+08:00
Monitoring
During this maintenance window, the KPL Site will be inaccessible. We appreciate your patience and understanding.
Posted Jul 07, 2021 - 11:35 GMT+08:00
This incident affected: Website, Android Application, and Web Application Firewall.